Timeline Error in Progressive Download

Jan 16, 2012 at 4:44 PM
Edited Jan 16, 2012 at 4:44 PM


Hello,

I´m using SmoothStreamingPlayer.xap from microsoft-smf-src-2.2011.1101.0.

When I play in progressive download and I seek using the timeline, the timeline doesn´t advance and the text that indicate the time doesn´t update. Nor runs SeekCompleted event either.

With AdaptiveStreaming works ok.

The code:

 

<div id="silverlightControlHost1" style="height: 100%; width:50%; float: left;">
        <object data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="95%" height="95%">
		  <param name="source" value="../../ClientBin/SmoothStreamingPlayer.xap"/>
		  <param name="background" value="white" />
		  <param name="minRuntimeVersion" value="4.0.50303.0" />
		  <param name="autoUpgrade" value="true" />
                  <param name="InitParams" value="scriptablename=Player,autoplay=true,DeliveryMethod=ProgressiveDownload,mediaurl=http://smf.vertigo.com/videos/wildlife.wmv" />
		  <a href="http://go.microsoft.com/fwlink/?LinkID=149156&v=4.0.50303.0" style="text-decoration:none">
 			  <img src="http://go.microsoft.com/fwlink/?LinkId=161376" alt="Get Microsoft Silverlight" style="border-style:none"/>
		  </a>
	    </object><iframe id="_sl_historyFrame" style="visibility:hidden;height:0px;width:0px;border:0px"></iframe>
</div>

<div id="silverlightControlHost2" style="height: 100%; width:50%; float: left;">
        <object data="data:application/x-silverlight-2," type="application/x-silverlight-2" width="95%" height="95%">
		  <param name="source" value="../../ClientBin/SmoothStreamingPlayer.xap"/>
		  <param name="background" value="white" />
		  <param name="minRuntimeVersion" value="4.0.50303.0" />
		  <param name="autoUpgrade" value="true" />
                  <param name="InitParams" value="scriptablename=Player, autoplay=true,DeliveryMethod=AdaptiveStreaming,mediaurl=http://ecn.channel9.msdn.com/o9/content/smf/smoothcontent/elephantsdream/Elephants_Dream_1024-h264-st-aac.ism/manifest" />
		  <a href="http://go.microsoft.com/fwlink/?LinkID=149156&v=4.0.50303.0" style="text-decoration:none">
 			  <img src="http://go.microsoft.com/fwlink/?LinkId=161376" alt="Get Microsoft Silverlight" style="border-style:none"/>
		  </a>
	    </object><iframe id="Iframe1" style="visibility:hidden;height:0px;width:0px;border:0px"></iframe>
</div>


Can anyone help me?