SSME Config Options

May 23, 2011 at 8:31 PM

I have been scouring the internet for some time now and I cannot find any place where the Smooth Streaming Media Element config file is explained. I found one person that had a commented file but it was for Live Smooth Streaming settings and when I try to use it my player crashes with a generic error.

Does anyone know of or have any documentation on configuring the Smooth Streaming Media Element settings?

May 24, 2011 at 12:18 PM

+1

I'd like to know where it is documented too.

 

Thank-you,

Luis

May 24, 2011 at 12:54 PM

+ 1

Count me in on this. Info on this would be great!

- Loke

May 27, 2011 at 8:48 AM

Maybe this post can help http://forums.iis.net/t/1172146.aspx

Martin

May 27, 2011 at 9:01 AM

Somebody's reverse engineered stuff, with guesses about how it works, well, i suppose its better than nothing, but its far from official documentation :)

- Loke

May 27, 2011 at 1:53 PM

Yep, I have seen that page and everytime I've tried to use that file, or even some version of it (like removing most of the config options) it causes the player to crash.

Coordinator
Jul 19, 2011 at 4:55 PM

I've been told that LiveBufferTimeMilliseconds has been removed from the config xml and is now a property of the SSME: http://msdn.microsoft.com/en-us/library/microsoft.web.media.smoothstreaming.smoothstreamingmediaelement.liveplaybackoffset(v=VS.90).aspx

If you are still having problems getting the player to accept a config.xml, please try removing this in the xml.