Accessing a WMV file on my web server

Apr 6, 2010 at 10:48 PM
Edited Apr 6, 2010 at 10:48 PM

I am creating my silverlight application on my local machine and am using Local IIS. the project runs on http://myMachine:123/ I have a folder called Videos with some wmv files. In the Source property of my SMF control, i tried setting it as "http://myMachine:123/Videos/video1.wmv" but this doesnt seem to play it.

Am I doing this right?


Aug 20, 2010 at 4:02 AM

I am also having the same problem. I am debugging using Visual Studio 2008's built-in web server and have set the Source property to http://localhost:1425/path/to/file, however, the video is not playing. Setting the Source property to does work though. Any hints?

Aug 24, 2010 at 6:04 PM

One problem I ran into when doing this was that the default IIS installation does not give your application the correct permissions when using "Pass Through Authentication". Therefore, make sure that the "Pass Through Account" has read access to the path where your video file is located. Usually, the "Pass Through Account" is the same account that your application's app pool is using. For normal installations this will be the Network Service built-in account.