Adding MMF 2.7 to Existing SL4 App Errors

Oct 11, 2012 at 7:29 PM

I have an existing SL4 app and I am receiving errors when loading the MMF 2.7 versions of Core, Plugins, advertising, Progressivedownloads and Utilities DLL's to my project.

This is one example but it repeats itself for all the DLL's listed above

The primary reference "Microsoft.SilverlightMediaFramework.Utilities" could not be resolved because it has an indirect dependency on the .NET Framework assembly "System.Windows.Browser, Version=5.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e" which has a higher version "5.0.5.0" than the version "2.0.5.0" in the current target framework. TestVideoProgressive

Looks like it wants to run only in SL5?

Please advise.

Thanks.