Removing the buffer notification on video load

Jun 29, 2011 at 4:04 PM

Hi there,

I was wondering what needs to be done in order to remove the buffering/loading notification when a video starts to load.

Thanks!

Coordinator
Jun 29, 2011 at 4:11 PM

Neykho, if you edit the template for the player in Blend you can remove the "buffering..." text (and replace it with what ever you'd like).

Tim

Jun 29, 2011 at 4:33 PM

Hi Tim, I'm aware of the buffering text. I apologize, I should have been more specific; what I'm actually referring to is the light-blue spinning animation that shows the loading progress.

Jun 29, 2011 at 5:33 PM
Edited Jun 29, 2011 at 5:41 PM

Neykho, you're looking for a Custom Loading Screen. The blue spinning animation is the default in all Silverlight browser apps and is not specific to the SMF / MMP player (it indicates how much of the Silverlight XAP file is downloaded). See here for an example: http://pagebrooks.com/archive/2009/02/19/custom-loading-screens-in-silverlight.aspx

One strategy that I would also recommend is making sure you store your XAP file with an infinite cache. For example, our Silverlight player on NimbusHD is stored on a URL like: http://nimbushd.com/Player/1.0.1.12/Player.xap with a no-expiration on cache. If we deploy a new player, we change the URL (increment the version folder to 1.0.1.13 or something). That way your users only see the loading animation the first time they load it in the browser and not on subsequent tries.

Jun 30, 2011 at 1:42 PM

Thanks for the link. Problem solved!