WP7 and mms audio streaming

May 27, 2011 at 8:36 AM

Hi everybody,

I want to stream mms protocol for radio streaming and I'm using SMF for WP7. I notice that I have some issues when I assign source at instance of SmoothStreamingMediaElement.

For example, I have to assign source again after that I start application, or another if I set source on xaml file start to play the audio streaming.

Please, can you suggest me any improvements for handle this object.

Thanks very much,


May 27, 2011 at 1:55 PM

You shouldnt use SmoothStreamingMediaElement on WP7 for streaming mms, since its not smooth streaming but regular streaming.

Also, with regards to MMS support on WP7 checkout http://social.msdn.microsoft.com/Forums/en-US/windowsphone7series/thread/31201eed-13ed-435c-8b00-291578e86e68/

- Loke

May 27, 2011 at 2:08 PM

Thanks very much Loke,

I saw that site long time ago but I didn't find solution in everypost, indeed SigurdS write that he had problems only with WP7. An important suggestion was to define a entry point (ex. http://server1.provider.com/radioxyz.wma but it works only with SmoothStreamingMediaElement.

Did you try to use MediaElement for make it?

thanks again,


May 27, 2011 at 2:15 PM

I havent tried it myself with mms streaming of WMA, but it seems in Dans response that SigurdS problem is not having an extension (like .wma og .wmv)

Also, MediaElement should be the correct for when you are not doing smooth streaming which it doesnt sound like you are, have you tried with MediaElement in normal Silverlight?

- Loke

May 27, 2011 at 2:48 PM

Yes, I tried with Silverlight and it works. I have the problem only with WP7...