Error when trying to play PlayReady in SilverLight

May 26, 2011 at 9:14 AM



My silverlight is trying to acquire license and my PlayReady server does return a license.

But then the silverlight shows this message:

MediaFailed: 6000 Unable to complete the operation due to an unexpected internal error.


What can this be???


Thank you

May 26, 2011 at 10:20 AM


As far as i know 6000 is kinda like a generic catchall error. This also seems to fit with

Have you tried playing back the PlayReady test content? On the MS test server?

- Loke

May 26, 2011 at 11:02 AM


on MSFT test medias/server my player works fine...

May 26, 2011 at 11:10 AM
Edited May 26, 2011 at 11:21 AM

Must I use the pre-delivery scenario? (the override of the




How can I debug the silverlight to understand what's going on with this error? any idea?

May 26, 2011 at 2:20 PM

Well, pre-delivery and a custom licenseacquirer is not the same thing really.

Depending on how you configured your PlayReady server you should just be able to use the built-in licenseacquirer.

Try looking at the network traffic using something like wireshark to see the request to your playready server, and what it returns.

Perhaps you could send me a link where i could test? You are welcome to email me.

- Loke

May 26, 2011 at 2:24 PM

I am starting to believe the problem is with the encoding&encrypting of the media.

I took a pyv from MSFT test site, and I am returning a license based on the key & seed they wrote and its working.

I also took the bear movie which is CLEAR and tried to encrypt it with the AESencryptor, and still it doesnt work...

Maybe i'm doing something wrong????

I took the sample AES tool...

May 26, 2011 at 2:26 PM

What AESencryptor? From where?

May 26, 2011 at 2:27 PM

from the SDK.

May 26, 2011 at 2:31 PM

Right, that should do it okay. Are you able to encrypt a file and send it to me perhaps?

- Loke

May 26, 2011 at 2:33 PM

Yes, ill message you in private

May 26, 2011 at 3:02 PM
Edited May 26, 2011 at 3:49 PM

Thanks! Problem was PlayRight was missing from the license!