Captions (MarkerResource) do not appear in 2.4

Apr 5, 2011 at 3:06 PM

Hi

In version 2.2 SMF I used MarkerResource for displaying subtitles. It worked well.

When I started using version 2.4 subtitles do not appear.

I use the format: TTAF1-DFXP

Did you met up with something similar ??

 

Coordinator
Apr 5, 2011 at 4:04 PM

elmo, there is a known bug with fontsizes using the cell unit, for example: tts:fontsize="1.5c"

Here's another thread about it: http://smf.codeplex.com/discussions/250007

Note: This issue has been fixed and will be available sometime next week.

Please let me know if this is not the issue you are encountering,

Tim Greenfield

Apr 6, 2011 at 8:54 AM

Hi

Thanks. I changed the font size , but I also must add to the style attribute origin and extent to see subtitles.

In smf-2.2 I had a file with this style defintion:

              <style xml:id="s1" tts:color="white" tts:fontFamily="proportionalSansSerif" tts:fontSize="0.8c" tts:textAlign="center"/>

             <region xml:id="subtitles" style="s1" tts:padding="5px 3px" tts:displayAlign="after"/>

and one of paragraph:

              <p begin="11.280s" end="15.440s" region="subtitles"><span tts:backgroundColor="#000000"> ABCDEFDSFS </span><br/><span tts:backgroundColor="#000000"> ZZCZCZ ERFEAS FSESFEEAS. </span><br/></p>

Subtitles worked well, showed up at the bottom screen, but In smf-2.4 I must (except change font size definition to px) add attributes origin and extent to style element.