Simple Question: Edit the look of the captions(regions)

Jul 20, 2010 at 3:48 PM

I'm needing to change the appearance of the captions DFXP when I use the player. I need to remove the black background, for example. How do I edit it?

Coordinator
Jul 20, 2010 at 11:15 PM

Are your captions being defined in a DFXP file/stream?  If so, just change the style according to the DFXP specification.  http://www.w3.org/TR/ttaf1-dfxp/

Otherwise, if you are doing this via code, the appearance can be modified by changing properties on CaptionRegion.Style.  For example, CaptionRegion.Style.BackgroundColor can be used to change the background color.

Jul 21, 2010 at 12:21 AM
Edited Jul 21, 2010 at 12:22 AM
Hello, thanks for replying!
What happens, I'm generating the captions directly from expression encoder, and it it has a default description in the caption stream that would be this one.
    <styling>
      <style xml:id="backgroundStyle" p5:fontFamily="Serif" p5:fontSize="1.5c" p5:textAlign="center" 

p5:origin="0% 90%" p5:extent="100% 8%" p5:backgroundColor="rgba(0,0,0,255)" p5:displayAlign="center" 

xmlns:p5="http://www.w3.org/2006/10/ttaf1#styling" />
      <style xml:id="speakerStyle" p5:style="backgroundStyle" p6:color="Green" p6:textOutline="0px 1px" 

p6:backgroundColor="transparent" xmlns:p6="http://www.w3.org/2006/10/ttaf1#styling" 

xmlns:p5="http://www.w3.org/2006/10/ttaf1" />
    </styling>
    <layout>
      <region xml:id="speaker" p5:style="speakerStyle" p6:zIndex="1" 

xmlns:p6="http://www.w3.org/2006/10/ttaf1#styling" xmlns:p5="http://www.w3.org/2006/10/ttaf1" />
      <region xml:id="background" p5:style="backgroundStyle" p6:zIndex="0" 

xmlns:p6="http://www.w3.org/2006/10/ttaf1#styling" xmlns:p5="http://www.w3.org/2006/10/ttaf1" />
    </layout>
In the EE template this have a look (background transparent) , but in the SMF player, this have a different look by default (black background). 
I change the style i, and nothing happens.  I thought I had something in the code overlapping this style of player, or do I need to create a region..
 I followed the procedures of styling of text that you sent, but do not know exactly how to do this in SMF. Editing the stream  nothing changes.
 I'm doing something wrong, just wanted to edit that style. Sorry for the english,
Jul 21, 2010 at 5:50 PM

I am with the same problem, I don't know if I accidentaly change the character code from the file, or if there is something in cache, I restart the iis, clean the cache in windows\microsoft.net...\framework... and nothing, any help in this topic will be great.

Jul 22, 2010 at 4:11 PM
I managed to solve the problem by editing the preferences file defaults CaptionStyle.cs ShowBackground DefaultShowBackground = ShowBackground.WhenActive; and Brush DefaultBackgroundColor = new SolidColorBrush (Colors.Transparent), the black background of the captions was not described in the file ISMT. Now another problem which I think should be simple. I'm corrupting the file extension when saving ISMT. Is it something in the encoding of the file, despite being described UTF-8 appears to save as ANSI, switching to unicode or UTF some corrupt anyway. Any tips for me to edit this file without corrupting it? What is the original encoding of that file ISMT? Thanks!